OSPF 02 – Configuração Básica no RouterOS

Introdução

Na semama passada escrevi um pouco sobre o protocolo e a forma como ele funciona. Pudemos ver o básico dos cabeçalhos e sobre as mensagens que ele troca. Se você perdeu pode ler a matéria aqui:

OSPF 01 – Introdução

Agora que já sabemos um pouco sobre as características do OSPF, vamos estabelecer uma sessão entre dois roteadores. O nosso cenário seria:

OSPF - Cenário 01

OSPF – Cenário 01

Configurando o OSPF no RouterOS

Agora vamos ao que interessa, que é colocar isso para funcionar com o nosso roteador de baixo custo favorito. O RouterOS tem suporte desde a versão 2.0, e as Routerboards constuma funcionar bem com todos os protocolos utilizados hoje em dia. O único que fica faltando é o pouco utilizado em terras tupiniquins IS-IS.

Configurar o OSPF é algo extremamente fácil no RouterOS. Você só precisar publicar as redes que deseja entre dois roteadores que são fisicamente ligados, e ele já coloca o protocolo para funcionar. Mas isso é o mínimo! Para funcionar bem são necessárias algumas boas práticas que abordaremos a seguir. Eu vou colocar uma configuração básica, e depois explico ela passo-a-passo.


Router 1

/interface bridge add name=loopback
/ip address
add address=192.168.0.1/32 interface=loopback
add address=10.1.1.1/30 interface=ether1
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-1 router-id=192.168.0.1
/routing ospf interface
add interface=ether1 network-type=broadcast priority=0
add interface=all network-type=broadcast passive=yes priority=0
/routing ospf network
add area=backbone network=192.168.0.1/32
add area=backbone network=10.1.1.0/30

Router 2

/interface bridge add name=loopback
/ip address
add address=192.168.0.2/32 interface=loopback
add address=10.1.1.2/30 interface=ether1
/routing ospf instance
set [ find default=yes ] router-id=192.168.0.2
/routing ospf interface
add interface=ether1 network-type=broadcast priority=0
add interface=all network-type=broadcast passive=yes priority=0
/routing ospf network
add area=backbone network=192.168.0.2/32
add area=backbone network=10.1.1.0/30

Em primeiro lugar, devemos utilizar um endereço na loopback. Isso facilita o monitoramente, já que muitas vezes pode-se chegar ao roteador por mais de um caminho. E se você quiser utilizar um IP público, você enconomiza utilizando IPs /32, mesmo que a rede inteira esteja rodando sobre IPs privados. Isso é até bom porque facilita a configuração do firewall. Além disso é uma interface que está sempre up. O RouterOS apesar de possuir a loopback, que você pode confirmar através de um simples ping, não nos permite utiliza-lá. Para remediar isso, podemos criar uma bridge sem nenhuma interface associada.

Obs.: A partir daí é só configurar um endereço e tá pronto. No OSPF v2 não é necessário um MAC na interface, mas ao utilizar IPv6, será necessário definir um Admin MAC para ela.

Depois disso nós configuramos a instância. Eu gosto de escolher o meu Router ID, e como o formato é igual do IP, se você não definir nenhum, o menor IP das interfaces do roteador será utilizado como Router ID.

Obs.: Outra coisa que configuramos, mas apenas se for o Border Router, é a distribuição da Rota Padrão.

OSPF Link types

Na seção de interfaces, uma boa prática é adicionar um interface como all e configurá-la como passiva. Dessa forma o roteador só enviará os pacotes hello para as interfaces que nos especificarmos, que no nosso exemplo é a ether1.

E por último declaramos a rede da interface do ponto a ponto, e o IP da loopback. Se no outro roteador estiver configurado da mesma forma, a excessão da rota default que só deve ser configurado em UM Roteador da Area do AS.

Mas essa é uma configuração básica. E em provedores que possuem enlaces via rádio, o pessoal muitas vezes tem problemas com o broadcast. Uma forma de contornar isso é utilizar a interface configurada como NBMA (Non-Broadcast Multi Access) ou PTP/PMTP (Point-To-Point/Point-To-Multi-Point). A diferença dos dois modos, é que no NBMA temos que configurar manualmente os neighbors, e definir os parâmetros de atualização deles, e existirá obrigatóriamente um DR e um BDR. Já no PTP/PMTP não há eleição de DR e BDR, o que resulta numa convergência ainda mais rápida do protocolo. Principalmente se você utiliza links com solução Ubiquiti e hosts Mikrotik nas pontas, o modo NBMA é uma excelente idéia. No Fórum do Mikrotik é sempre a recomendação dada, e você pode conferir isso aqui.

Para esse caso, o nosso exemplo ficaria assim:

Router 1

/interface bridge add name=loopback
/ip address
add address=192.168.0.1/32 interface=loopback
add address=10.1.1.1/30 interface=ether1
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-1 router-id=192.168.0.1
/routing ospf interface
add interface=ether1 network-type=nbma priority=0
add interface=all network-type=broadcast passive=yes priority=0
/routing ospf nbma-neighbor
add address=10.1.1.2 disabled=no instance=default poll-interval=2m priority=0
/routing ospf network
add area=backbone network=192.168.0.1/32
add area=backbone network=10.1.1.0/30

Router 2

/interface bridge add name=loopback
/ip address
add address=192.168.0.2/32 interface=loopback
add address=10.1.1.2/30 interface=ether1
/routing ospf instance
set [ find default=yes ] router-id=192.168.0.2
/routing ospf interface
add interface=ether1 network-type=nbma priority=0
add interface=all network-type=broadcast passive=yes priority=0
/routing ospf nbma-neighbor
add address=10.1.1.1 disabled=no instance=default poll-interval=2m priority=0
/routing ospf network
add area=backbone network=192.168.0.2/32
add area=backbone network=10.1.1.0/30

Bem, é isso! Se você tiverem dúvidas, podem perguntar aí nos comentários. E quem precisar de uma consultoria específica, é só avisar.

Uma coisa que recomendo a todos que puderem, é fazer um treinamento. Eu já tive oportunidade de realizar um MTCNA/MTCRE com a Lancore, e o instrutor Guilherme Ramirez, e este ano fiz um treinamento de MTCRE/MTCINE (eles apresentam conjugados) com o pessoal da MD Brasil e o Wadner Maia, Sérgio Souza e Edson Xavier Veloso Jr. como instrutores. São todos profissionais muito capazes e quem fizer o treinamento com eles vai aprender bastante. Eu recomendo e olha que nem tô ganhando nenhum jabá para isso, rs.

Referência

OSPF Wikipedia [português]
OSPF Wikipedia [english]
Wiki Mikrotik OSPF
RFC 1131
RFC 2328
RFC 5340
Cisco OSPF Design Guide
Cisco OSPF
O Protocolo OSPF – Jailton Santos das Neves, Waldeck Ribeirto Torres – UFF
Protocolos de Roteamento RIP e OSPF – Alexandre Urtado de Assis e Nilton Alves Jr. – CBPF
O Protocolo OSPF – Prof. José Gonçalves – UFES
Protocolo OSPF parte 1 e parte 2 – DL Tec do Brasil

Anúncios

14 Comentários on “OSPF 02 – Configuração Básica no RouterOS”

  1. Davi nunes disse:

    Aqui onde trabalho tenho 22 torres de transmissão, todas em ospf.
    Só que algumas delas as rotas ficam caindo toda hora. Daí como não sei o que está causando isto, setei como estáticas as rotas que não estão “segurando”…

    • Eu deixo rotas estáticas com um custo de 120 para as interfaces primárias das torres. Se você estiver usando routerboard+ubuiquiti pode ser a LAN. Checa se está tudo OK com cabos e etc. E configure em NBMA ou PTP/PTMP e costuma ficar mais estável.

  2. Sandro Marani disse:

    Luciano, minha duvida é o seguinte. Tenho uma rede corporativa (não provedor) e fecho VPN-Site-to-Site entre matriz e filiais sempre utilizando rota-estatica. Você ve alguma forma de utilizar OSPF nesta situação. Inclusive me dando condições de conectar filiais diretamente. Hoje todas fecham no meu ponto concentrador.

  3. Renato P. disse:

    Luciano, quando deixo all interfaces em passivo e a ether1 em nbma, estou dizendo para o ospf distribuir rotas para o meu nbma vizinho, e para os restos das interfaces não? CORRETO?

  4. Como eu faço para transferir o ospf do meu border router para meu core router?

  5. Samuel disse:

    Amigo tou querendo deixa a minha rede roteada ospf, tenho dois links e tou querendo os dois mais eles estão em pontos diferentes, minha pergunta é posso configurar as redes pra se enxergarem e quando um link cair o outro entrar. Grato

  6. Fabiano disse:

    Luciano, parabéns pela iniciativa, ótimo tutorial. Consegui subir OSPF entre meu balance e concentrador seguindo a sua dica.

    Após subir e testar, está funcionando perfeitamente, criando as rotas dinamicas e tudo mais, unico detalhe que após subir o OSPF meus acessos externos parou de funcionar. Esses acessos são p/ cameras, TS, DVR e outros, até o meu acesso ao concentrador quando estou fora da rede parou.

    Te pergunto, isso é previsto por causa do OSPF ou era p/ continuar funcionando normal ?

    Abraço.

  7. Elton disse:

    Cara você me ajudou muito nessa questão do nbma, muito obrigado !!! excelente material.

  8. Francisco Benedito Bueno disse:

    boa noite!! Tenho uma rede em ospf , e dois links em lugares diferentes, gostaria de saber como faço para que eu consiga distribuir entre os pops os links, exemplo: Link 1 para o pop 1,2,3 e 4 e link 2 para os pops 5,6,7,8,9 e 10. Um link se encontra no pop1 e outro no pop 2


Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s